Enable the libusb on your system.

NT software on Linux testing.
usbbdm
Junior Member
Posts: 8878
Joined: Mon Jul 18, 2005 9:33 pm

Post by usbbdm »

Does this happen on NT main software? There are slightly difference on how to handle the USB. UJmodem was build on older way. I can rebuild UJmodem to use new way if NT software do not have this issue.
Koevoet
Junior Member
Posts: 298
Joined: Sat Nov 18, 2006 8:29 am

Post by Koevoet »

longjon wrote:I tried that even restarted my computer and ran ujmodem from the terminal
as root and I still get the same thing over and over again could it be something with the application permissions or a driver conflict
Run this command as root:

modprobe -r usbtest

You may have to blacklist this as per above posts .

Regards
longjon
Junior Member
Posts: 8
Joined: Wed Aug 12, 2009 6:17 am

Post by longjon »

Thank you usbbdm and Thanks to you Koevoet The gedit modprobe -r usbtest worked for me I really appreciate your help and support you guys are the best
keep up the great work........:D
P1ro
Junior Member
Posts: 5
Joined: Fri May 20, 2011 2:06 pm

keeps restarting

Post by P1ro »

App opens fine i think but the usb conect and disconnect is not even reading the SN
dmesg:

Code: Select all

[  958.448042] usb 1-2: new high-speed USB device number 19 using ehci-pci
[  958.580773] usb 1-2: New USB device found, idVendor=04b4, idProduct=8613
[  958.580780] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  958.580784] usb 1-2: Product: USBJTAGNT
[  958.580788] usb 1-2: Manufacturer: USBJTAGNT
[  958.581242] usbtest 1-2:1.0: FX2 device
[  958.581253] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  958.754826] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  959.764041] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  959.896480] usbtest 1-2:1.0: FX2 device
[  959.896487] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  959.896655] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  959.896780] usb 1-2: usbfs: process 2663 (C18cc0441) did not claim interface 0 before use
[  960.012052] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  960.144514] usbtest 1-2:1.0: FX2 device
[  960.144522] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  960.396986] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  960.508050] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  960.640457] usbtest 1-2:1.0: FX2 device
[  960.640465] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  960.640650] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  960.840038] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  960.972494] usbtest 1-2:1.0: FX2 device
[  960.972501] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  962.172808] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  963.184040] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  963.316433] usbtest 1-2:1.0: FX2 device
[  963.316441] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  963.316635] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  963.316710] usb 1-2: usbfs: process 2663 (C18cc0441) did not claim interface 0 before use
[  963.432217] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  963.564481] usbtest 1-2:1.0: FX2 device
[  963.564489] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  963.816827] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  963.928047] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  964.060419] usbtest 1-2:1.0: FX2 device
[  964.060429] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[  964.060542] usb 1-2: usbfs: interface 0 claimed by usbtest while 'C18cc0441' sets config #1
[  964.260040] usb 1-2: reset high-speed USB device number 19 using ehci-pci
[  964.392448] usbtest 1-2:1.0: FX2 device
[  964.392455] usbtest 1-2:1.0: high-speed {control bulk-in bulk-out} tests (+alt)
[email protected]:/home/p1ro/cm/usbjtag/usbjtagnt# 
lsusb:

Code: Select all

Bus 001 Device 020: ID 04b4:8613 Cypress Semiconductor Corp. CY7C68013 EZ-USB FX2 USB 2.0 Development Kit
same happend as root

using xubuntu 32bits.
usbbdm
Junior Member
Posts: 8878
Joined: Mon Jul 18, 2005 9:33 pm

Post by usbbdm »

If you see USB connected and disconnected, this often happens when you have TWO application trying to access the device. This can happen on Windows too.
If you start Ujmodme and USB JTAG NT at the same time, you might see USB connect and disconnected.

In your case do you have another application (even USB monitoring app)?
P1ro
Junior Member
Posts: 5
Joined: Fri May 20, 2011 2:06 pm

Post by P1ro »

well i cant see any, and im only using one app at time UJmodem or USBJTAGNT
Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest