mvidea fs 4000

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:) :o :D ;) :p :mad: :confused: :( :shock: :? 8) :lol: :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :rolleyes:

BBCode is OFF
Smilies are ON

Topic review
   

Expand view Topic review: mvidea fs 4000

by slugworth » Sun Nov 16, 2014 8:10 am

I tried old v0.56 with a ram address of 0x0 size 100000 and was finally able to program with sprogram
even that only worked 10% of the time.

by slugworth » Mon Nov 10, 2014 9:12 pm

the receiver has no eeprom,if that makes any difference

by usbbdm » Mon Nov 10, 2014 9:26 am

<Inits>
<Init>
<Address>0x30010020</Address>
<Value>0xfC0</Value>
</Init>
</Inits>

are missing.

by usbbdm » Mon Nov 10, 2014 9:24 am

If you do not use teamviewer I cannot help you.
<Address>0x20000000)</Address>
Might be wrong.
Also I think you size should be
<Size>0x100000</Size>

not
<Size>0x10000</Size>

Something else to check flash is blanked after erase.

by slugworth » Mon Nov 10, 2014 6:14 am

I think the minimum just for programming the boot section,but still won't work

<Test>
<Name>mvidea2</Name>
<Cat>DishIrd</Cat>
<Protocol>ARM9</Protocol>
<SubProtocol>ARM920</SubProtocol>
<conexant>1</conexant>
<Endian>Little</Endian>
<IRLength>8</IRLength>
<DMA>No</DMA>
<Programram>0x200000</Programram>
<Memorys>
<Memory>
<Name>ram</Name>
<Type>0</Type>
<Address>0x200000</Address>
<Size>0x10000</Size>
</Memory>
<Memory>
<Name>boot</Name>
<Type>1</Type>
<Address>0x20000000)</Address>
<Size>0x10000</Size>
</Memory>
</Memorys>
</Test>

by slugworth » Sun Nov 09, 2014 6:20 pm

it should be the same as the viewsat except for the flash type/size

by usbbdm » Sun Nov 09, 2014 5:30 pm

Your XML does not look right compared to what you are trying to do.

by usbbdm » Sun Nov 09, 2014 5:25 pm

slugworth wrote:it gets stuck here,no progress bar

Copyright (C) 2010-2015
USB JTAG NT 0.71a
Target: Mvidea
-detect
IDCODE 20920027
Conexant (ARM920)
Found Address= 20000000 AMD AM29LV800BB
-erase 20000000 100000
Erase starts...
Erase time 00:00:06 (.484)
-erase Boot
Erase starts...
Erase time 00:00:00 (.813)
-ldram Boot
C:/jtag/3/boot125.bin loaded
-speed 1
-program Boot
Erase starts...
Have you modified the program ram?

by slugworth » Sun Nov 09, 2014 5:11 pm

it gets stuck here,no progress bar

Copyright (C) 2010-2015
USB JTAG NT 0.71a
Target: Mvidea
-detect
IDCODE 20920027
Conexant (ARM920)
Found Address= 20000000 AMD AM29LV800BB
-erase 20000000 100000
Erase starts...
Erase time 00:00:06 (.484)
-erase Boot
Erase starts...
Erase time 00:00:00 (.813)
-ldram Boot
C:/jtag/3/boot125.bin loaded
-speed 1
-program Boot
Erase starts...

by slugworth » Sun Nov 09, 2014 5:07 pm

it's a 1meg flash
s29al008 flash
I even tried adding <amd>1</amd> still nothing

by usbbdm » Sun Nov 09, 2014 4:53 pm

Most likely you have put the wrong
<Programram>0x100000</Programram>

Try to use "erase" and "sprogram" to see if it fixes the issue.

by usbbdm » Sun Nov 09, 2014 4:47 pm

slugworth wrote:- <Test>
<Name>mvidea</Name>
<Cat>DishIrd</Cat>
<Protocol>ARM9</Protocol>
<SubProtocol>ARM920</SubProtocol>
<Conexant>1</Conexant>
<Endian>Little</Endian>
<IRLength>8</IRLength>
<Programram>0x100000</Programram>
- <Memorys>
- <Memory>
<Name>boot</Name>
<Type>1</Type>
<Address>0x20000000</Address>
<Size>0x10000</Size>
</Memory>
</Memorys>
</Test>
I am in IRC chat.

by slugworth » Sun Nov 09, 2014 4:31 pm

- <Test>
<Name>mvidea</Name>
<Cat>DishIrd</Cat>
<Protocol>ARM9</Protocol>
<SubProtocol>ARM920</SubProtocol>
<Conexant>1</Conexant>
<Endian>Little</Endian>
<IRLength>8</IRLength>
<Programram>0x100000</Programram>
- <Memorys>
- <Memory>
<Name>boot</Name>
<Type>1</Type>
<Address>0x20000000</Address>
<Size>0x10000</Size>
</Memory>
</Memorys>
</Test>

by slugworth » Sun Nov 09, 2014 4:28 pm

when you make a .xml from scratch,it doesn't add the
<conexant>1</conexant> after the subprotocol,I had to add it manually or else I get
Copyright (C) 2010-2015
USB JTAG NT 0.71a
Target: mvidea
-detect
IDCODE 20920027
Conexant (ARM920)
Unknown flash type!
Report these values http://www.usbjtag.com/vbforum 5b07,663e

and also it saves it as modem type,instead of DishIrd
now I get
Copyright (C) 2010-2015
USB JTAG NT 0.71a
Target: mvidea
-detect
IDCODE 00000000
-detect
IDCODE 20920027
Conexant (ARM920)
Found Address= 20000000 AMD AM29LV800BB

but it still doesn't erase the flash

by usbbdm » Sun Nov 09, 2014 3:39 pm

Then put your xml here.

Top