SB6141 +forceWare ~ What am I doing wrong? (gift from newbie inside)

JTAG work on Surfboard cable modem.

Moderator: justsomeguy

Posts: 1
Joined: Sun Sep 10, 2017 3:39 am

SB6141 +forceWare ~ What am I doing wrong? (gift from newbie inside)

Post by the_majestic_bee » Sun Sep 10, 2017 9:47 pm

*** FULL DISCLOSURE: I'm a happily cheaply subscribed AT&T customer; I'm happy with my 50mbps at $30 ***

OBJECTIVE: Take full control of an old cablemodem for testing purposes; learn about SNMP; install forceWare; etc.

DEVICE 1: SB6141 running SB_KOMODO-1-0-6-16-SCM00-NOSH
CHIP: MX25L6405D
DEVICE 2: WMB760a running ??? (haven't tried anything just yet)

& latest JTAG device (3 weeks old)

I have the following *.bin files:
SB_KOMODO-1-0-6-16-SCM00-NOSH.bin (backup from sb6141 in case everything goes haywire)

Hello everyone,
Newbie here.

I've gone as far as I can with research and searching this forum, HXW and SBH (defunct?)
I've dedicated as much as 20 hours to accomplishing this but trying to learn is frustrating me :(
Thanks to Mr. CAPONE and everyone else, I've learned to use everything I've listed above to erase the chip, reprogram it, verify the data
To keep things foolproof, I always verify what I write, write at -2 speed using 5V (chip specs from datasheet call for 3.3V on the VCC pin2... that's another story very well discussed here and how hungry the SB6141 is for power). Enough of that.

I like the idea of SSH, root, SNMP and running forceWare and was super tough to find the BIN files (who hosts the "official" latest anyway?)
So far I've been rewriting to "AllFlash" but it seems writing to different parts of the memory is the trick.
Every *.bin I've ever flashed into "AllFlash" give me the dreaded 3 blue LED lights (no ping response so cannot SSH).

I've also tried writing forceWare bin files into UBFI1 and UBFI2 but modem still refuses to boot or ping.
I think the key is on how I write to the chip; etc. I understand the concept of memory addresses and blocks but have ZERO experience.

What do you think I'm doing wrong? besides not searching harder - ;)
Am I using the wrong files?

My only contribution I can give, my gift to you:
close up pics of the WMB760A board.


Posts: 1
Joined: Wed Feb 12, 2020 5:14 am

Re: SB6141 +forceWare ~ What am I doing wrong? (gift from newbie inside)

Post by billycurious » Wed Feb 12, 2020 7:06 am

did you ever figure it out?

Post Reply